[slurm-users] Issue with "hetjob" directive with heterogeneous job submission script

Renfro, Michael Renfro at tntech.edu
Thu Mar 5 15:36:02 UTC 2020

I’m going to guess the job directive changed between earlier releases and 20.02. An version of the page from last year [1] has no mention of hetjob, and uses packjob instead.

On a related note, is there a canonical location for older versions of Slurm documentation? My local man pages are always consistent with the installed version, but lots of people Google part of their solution, and are always pointed to documentation for the latest stable release.

[1] https://web.archive.org/web/20191227221359/https://slurm.schedmd.com/heterogeneous_jobs.html
Mike Renfro, PhD / HPC Systems Administrator, Information Technology Services
931 372-3601     / Tennessee Tech University

> On Mar 4, 2020, at 2:05 PM, CB <cbalways at gmail.com> wrote:
> External Email Warning
> This email originated from outside the university. Please use caution when opening attachments, clicking links, or responding to requests.
> Hi,
> I'm running Slurm 19.05.5.
> I've tried to write a job submission script for a heterogeneous job following the example at https://slurm.schedmd.com/heterogeneous_jobs.html
> But it failed with the following error message:
> $ sbatch new.bash
> sbatch: error: Invalid directive found in batch script: hetjob
> Below is the new.bash job script:
> $ cat new.bash
> #!/bin/bash
> #SBATCH --cpus-per-task=4 --mem-per-cpu=16g --ntasks=1
> #SBATCH hetjob
> #SBATCH --cpus-per-task=2 --mem-per-cpu=1g  --ntasks=8
> srun exec_myapp.bash
> Has anyone tried this?
> I've tried the following command at the command line and it worked fine. 
> $ sbatch --cpus-per-task=4 --mem-per-cpu=16g --ntasks=1 : --cpus-per-task=2 --mem-per-cpu=1g  --ntasks=8 exec_myapp.bash
> Thanks,
> Chansup

More information about the slurm-users mailing list