[slurm-users] Issue with "hetjob" directive with heterogeneous job submission script

CB cbalways at gmail.com
Wed Mar 4 20:05:50 UTC 2020


I'm running Slurm 19.05.5.

I've tried to write a job submission script for a heterogeneous job
following the example at https://slurm.schedmd.com/heterogeneous_jobs.html

But it failed with the following error message:

$ sbatch new.bash
sbatch: error: Invalid directive found in batch script: hetjob

Below is the new.bash job script:
$ cat new.bash
#SBATCH --cpus-per-task=4 --mem-per-cpu=16g --ntasks=1
#SBATCH hetjob
#SBATCH --cpus-per-task=2 --mem-per-cpu=1g  --ntasks=8
srun exec_myapp.bash

Has anyone tried this?

I've tried the following command at the command line and it worked fine.
$ sbatch --cpus-per-task=4 --mem-per-cpu=16g --ntasks=1 : --cpus-per-task=2
--mem-per-cpu=1g  --ntasks=8 exec_myapp.bash

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20200304/9691a2c9/attachment.htm>

More information about the slurm-users mailing list