[slurm-users] Configure Slurm 17.11.9 in Ubuntu 18.10 with use of PMI

Pär Lundö par.lundo at foi.se
Mon Jun 24 14:39:47 UTC 2019

Thank you so much for your quick resplies, it is much appreciated. Im 
sorry for my late response, but I havent been able to check the thread 
nor did I except such quick response!

I just managed to build a new version of Slurm version 19.05 with PMIX 
v3.1. It seems to work without error when starting a MPI-program with 
the command srun.

I do though have some additional questions.

 1. Prior to the installation of Slurm version 19.05 I tried to remove
    the former installation of Slurm via the package tool in Ubuntu
    (apt), but all of the files or dependencies have not been removed.
     1. I cannot start the services (slurmctld and slurmd) via
        systemctl. The error stated by systemctl is
     2. For slurmd-service:
        "slurmd.service: Failed with result 'protocol
        Failed to start LSB: slurm daemon management"
     3. For slurmctld.service:
        "systemd[1]: Starting LSB: slurm daemon management...
        slurmctld[4531]: Not starting slurmctld
        slurmctld[4531]: slurm.conf was not found in /etc/slurm-llnl
        lurmctld[4531]: Please follow the instructions in
        systemd[1]: slurmctld.service: Can't open PID file
        /var/run/slurm-llnl/slurmctld.pid (yet?) after start: No such
        file or directo
        systemd[1]: slurmctld.service: Failed with result 'protocol'.
        systemd[1]: Failed to start LSB: slurm daemon management."
     4. So why is the folder /var/run/slurm-llnl/ searched? I must have
        missed out on changing the /<sysconfdir>/ during configuration.
     5. However I manage to start both of the services manually from the
        build dir (<buidlDir>/src/slurmd/slurmd/ and
        <buildDir>/src/slurmctld/ respectively)

@John Hearns: I am not currently running any cluster or HPC software. I 
am testing the Slurm installation on a single node (a notebook for the 
moment). I dont plan on installing any additional software as of now, 
but I am interested in knowing what works and what works even better :)

Best regards

Palle L

On 2019-06-20 19:44, Philip Kovacs wrote:
> Also look for the presence of the slurm mpi plugins: mpi_none.so, 
> mpi_openmpi.so, mpi_pmi2.so, mpi_pmix.so, mpi_pmix_v3.so,
> They will be installed typically to /usr/lib64/slurm/. Those plugins 
> are used for the various mpi capabilities and are good "markers"
> for how your configure detected and built the mpi components.
> On Thursday, June 20, 2019, 1:22:59 PM EDT, Fulcomer, Samuel 
> <samuel_fulcomer at brown.edu> wrote:
> Hi Palle,
> You should  probably get the latest stable SLURM version from 
> www.schedmd.com <http://www.schedmd.com> and use the build/install 
> instructions found there. Note that you should check for WARNING 
> messages in the config.log produced by SLURM's configure, as they're 
> the best place to find you've missing packages that may be useful.
> When configuring OpenMPI, you'll want to use "--with-pmi=/usr/local" 
> if you build SLURM and install it into /usr/local. You'll probably 
> also want "--enable-mpi-cxx".
> Regards,
> Sam
> On Thu, Jun 20, 2019 at 12:33 PM Pär Lundö <par.lundo at foi.se 
> <mailto:par.lundo at foi.se>> wrote:
>     Dear all,
>     I have been following this mailinglist for some time, and as a
>     complete newbie using Slurm I have learned some lessons from you.
>     I have an issue with building and configuring Slurm to use OpenMPI.
>     When running srun for some task I get the error stating that Slurm
>     has not been built or configured to use MPI and I am advised to
>     rebuild it accordingly.
>     i have taken the following steps in order to configure and build
>     Slurm with OpenMPI (or PMI2, it really doesnt matter for me right
>     now, I just want to have the know how on this such configuration
>     should be made).
>      1. Download source-code via "apt-get source slurm-llnl" (current
>         version for Ubuntu 18.10 is 17.11.9)
>      2. Extracted the source code from the slurm-llnl_17.11.9-1.dsc"
>      3. cd to source dir
>          1. First I ran the following steps:
>              1. "./configure --with-pmi"
>              2. "debuild -i -us -uc -b" -> Fails.
>          2. I then ran the following steps (noting that the
>             "debuild-command" overwrites some configuration, thus I
>             added "--with-pmi" for that case):
>              1. debuild -i -us -uc -b" -> Fails
>     I followed the same procedure when configuring OpenMPI to be built
>     with Slurm, which worked after some back and forth with clean
>     commands.
>     Any suggestions as to why this does not work?
>     I must be missing out on something very basic, because Slurm must
>     surely be used with Ubuntu and OpenMPI .
>     Best regards,
>     Palle
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20190624/622a800a/attachment.html>

More information about the slurm-users mailing list