[slurm-users] Help with configure Slurm 17.11.9 in Ubuntu 18.10 to OPMI

Pär Lundö par.lundo at foi.se
Thu Jun 20 16:13:14 UTC 2019

Dear all,

I have been following this mailinglist for some time, and as a complete 
newbie using Slurm I have learned some lessons from you.

I have an issue with building and configuring Slurm to use OpenMPI.

When running srun for some task I get the error stating that Slurm has 
not been built or configured to use MPI and I am advised to rebuild it 

i have taken the following steps in order to configure and build Slurm 
with OpenMPI (or PMI2, it really doesnt matter for me right now, I just 
want to have the know how on this such configuration should be made).

 1. Download source-code via "apt-get source slurm-llnl" (current
    version for Ubuntu 18.10 is 17.11.9)
 2. Extracted the source code from the slurm-llnl_17.11.9-1.dsc"
 3. cd to source dir
     1. First I ran the following steps:
         1. "./configure --with-pmi"
         2. "debuild -i -us -uc -b" -> Fails.
     2. I then ran the following steps (noting that the
        "debuild-command" overwrites some configuration, thus I added
        "--with-pmi" for that case):
         1. debuild -i -us -uc -b" -> Fails

I followed the same procedure when configuring OpenMPI to be built with 
Slurm, which worked after some back and forth with clean commands.

Any suggestions as to why this does not work?

I must be missing out on something very basic, because Slurm must surely 
be used with Ubuntu and OpenMPI .

Best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20190620/6337f299/attachment.html>

More information about the slurm-users mailing list