[slurm-users] Configure Slurm 17.11.9 in Ubuntu 18.10 with use of PMI

Philip Kovacs pkdevel at yahoo.com
Thu Jun 20 17:44:04 UTC 2019

 Also look for the presence of the slurm mpi plugins:  mpi_none.so, mpi_openmpi.so, mpi_pmi2.so, mpi_pmix.so, mpi_pmix_v3.so,  They will be installed typically to /usr/lib64/slurm/.  Those plugins are used for the various mpi capabilities and are good "markers"for how your configure detected and built the mpi components.
    On Thursday, June 20, 2019, 1:22:59 PM EDT, Fulcomer, Samuel <samuel_fulcomer at brown.edu> wrote:  
 Hi Palle,
You should  probably get the latest stable SLURM version from www.schedmd.com and use the build/install instructions found there. Note that you should check for WARNING messages in the config.log produced by SLURM's configure, as they're the best place to find you've missing packages that may be useful.
When configuring OpenMPI, you'll want to use "--with-pmi=/usr/local" if you build SLURM and install it into /usr/local. You'll probably also want "--enable-mpi-cxx".
On Thu, Jun 20, 2019 at 12:33 PM Pär Lundö <par.lundo at foi.se> wrote:

Dear all,

I have been following this mailinglist for some time, and as a complete newbie using Slurm I have learned some lessons from you.
I have an issue with building and configuring Slurm to use OpenMPI.
When running srun for some task I get the error stating that Slurm has not been built or configured to use MPI and I am advised to rebuild it accordingly.
i have taken the following steps in order to configure and build Slurm with OpenMPI (or PMI2, it really doesnt matter for me right now, I just want to have the know how on this such configuration should be made).
   - Download source-code via "apt-get source slurm-llnl" (current version for Ubuntu 18.10 is 17.11.9)
   - Extracted the source code from the slurm-llnl_17.11.9-1.dsc"
   - cd to source dir
   - First I ran the following steps:
   - "./configure --with-pmi"
   - "debuild -i -us -uc -b" -> Fails.
   - I then ran the following steps (noting that the "debuild-command" overwrites some configuration, thus I added "--with-pmi" for that case):
   - debuild -i -us -uc -b" -> Fails

I followed the same procedure when configuring OpenMPI to be built with Slurm, which worked after some back and forth with clean commands.

Any suggestions as to why this does not work?
I must be missing out on something very basic, because Slurm must surely be used with Ubuntu and OpenMPI .
Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20190620/d85ac3e3/attachment.html>

More information about the slurm-users mailing list