[slurm-users] Plugins failing on Slurm v22 build Rocky Linux 9

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Tue Nov 29 09:03:24 UTC 2022

Hi Mark,

I'm glad you found the solution!  I recommend to use Cgroups 
(proctrack/cgroup), see the manual pages cgroup.conf and slurm.conf and


On 29-11-2022 09:44, Mark Holliman wrote:
> Thanks for replying. I installed a fresh version of RockyLinux 9.1. I mentioned Fedora 9 and CentOS 9 (Stream) simply because they tend to be compatible, and something that works on them is likely to work on Rocky9.
> I am building the RPMs from tarball, following instructions near identical to those you link (the ones on the Slurm website). I originally followed them exactly, which resulted in an install with the error I posted below. Searching online for that error led me to the suggested fix of turning off the system hardening and rebuilding/reinstalling, but this didn't solve the problem either.
> I turned up debugging and went through my config line by line and found the offending plugin is set at: JobAcctGatherType=proctrack/linuxproc
> I've replaced this with: JobAcctGatherType=jobacct_gather/linux and now the system starts. I suppose the old plugin is no longer/used supported and I missed it in the docs somewhere.
> Thanks!
> Cheers,
>    Mark
> -----Original Message-----
> From: slurm-users <slurm-users-bounces at lists.schedmd.com> On Behalf Of Ole Holm Nielsen
> Sent: 28 November 2022 19:06
> To: slurm-users at lists.schedmd.com
> Subject: Re: [slurm-users] Plugins failing on Slurm v22 build Rocky Linux 9
> This email was sent to you by someone outside the University.
> You should only click on links or attachments if you are certain that the email is genuine and the content is safe.
> Hi Mark,
> Did you upgrade to the RockyLinux 9.1 which has just come out?  Why do you talk about Fedora 9 (now we have Fedora 37) and CentOS 9 (non-existent)?
> Have you tried building Slurm RPM packages from the tar-ball?  Check out https://wiki.fysik.dtu.dk/Niflheim_system/Slurm_installation/#build-slurm-rpms
> After installing prerequisites, the command is simply:
> $ rpmbuild -ta slurm-$VER.tar.bz2 --with mysql
> If this fails, someone would have to submit a bug report against EL9 to SchedMD.
> Personal opinion: I would not recommend Slurm packages from EPEL.
> /Ole
> On 28-11-2022 17:35, Mark Holliman wrote:
>> I’m trying to build/install/run Slurm 22.05.6 on a Rocky Linux 9
>> (Fedora
>> 9) system, but the slurmctld service fails at startup with:
>> fatal: plugin_load_and_link: Plugin loading failed due to missing
>> symbols. Plugin is corrupted.
>> I’ve tried editing the slurm.spec file as specified here:
>> https://bugs.schedmd.com/show_bug.cgi?id=8438
>> <https://bugs.schedmd.com/show_bug.cgi?id=8438> but that hasn’t solved
>> the problem. I added the lines below at the start of the file, and
>> when that didn’t work I added them in the %build section as well, but
>> neither have fixed the problem.
>> # Disable hardened builds. -z,now or -z,relro breaks the plugin stack
>> %undefine _hardened_build
>> %global _hardened_cflags "-Wl,-z,lazy"
>> %global _hardened_ldflags "-Wl,-z,lazy"
>> Does anyone here have a working recipe for building Slurm v22 on a
>> Fedora 9 system (CentOS9, Rocky9)? Is there an expected delivery date
>> for official Slurm packages in EPEL 9 yet?

More information about the slurm-users mailing list