[slurm-users] Plugins failing on Slurm v22 build Rocky Linux 9

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Mon Nov 28 19:06:20 UTC 2022

Hi Mark,

Did you upgrade to the RockyLinux 9.1 which has just come out?  Why do 
you talk about Fedora 9 (now we have Fedora 37) and CentOS 9 

Have you tried building Slurm RPM packages from the tar-ball?  Check out 
After installing prerequisites, the command is simply:
$ rpmbuild -ta slurm-$VER.tar.bz2 --with mysql

If this fails, someone would have to submit a bug report against EL9 to 

Personal opinion: I would not recommend Slurm packages from EPEL.


On 28-11-2022 17:35, Mark Holliman wrote:
> I’m trying to build/install/run Slurm 22.05.6 on a Rocky Linux 9 (Fedora 
> 9) system, but the slurmctld service fails at startup with:
> fatal: plugin_load_and_link: Plugin loading failed due to missing 
> symbols. Plugin is corrupted.
> I’ve tried editing the slurm.spec file as specified here: 
> https://bugs.schedmd.com/show_bug.cgi?id=8438 
> <https://bugs.schedmd.com/show_bug.cgi?id=8438> but that hasn’t solved 
> the problem. I added the lines below at the start of the file, and when 
> that didn’t work I added them in the %build section as well, but neither 
> have fixed the problem.
> # Disable hardened builds. -z,now or -z,relro breaks the plugin stack
> %undefine _hardened_build
> %global _hardened_cflags "-Wl,-z,lazy"
> %global _hardened_ldflags "-Wl,-z,lazy"
> Does anyone here have a working recipe for building Slurm v22 on a 
> Fedora 9 system (CentOS9, Rocky9)? Is there an expected delivery date 
> for official Slurm packages in EPEL 9 yet?

More information about the slurm-users mailing list