[slurm-users] Plugins failing on Slurm v22 build Rocky Linux 9

Mark Holliman msh at roe.ac.uk
Mon Nov 28 16:35:55 UTC 2022


I'm trying to build/install/run Slurm 22.05.6 on a Rocky Linux 9 (Fedora 9) system, but the slurmctld service fails at startup with:

fatal: plugin_load_and_link: Plugin loading failed due to missing symbols. Plugin is corrupted.

I've tried editing the slurm.spec file as specified here: https://bugs.schedmd.com/show_bug.cgi?id=8438 but that hasn't solved the problem. I added the lines below at the start of the file, and when that didn't work I added them in the %build section as well, but neither have fixed the problem.

# Disable hardened builds. -z,now or -z,relro breaks the plugin stack
%undefine _hardened_build
%global _hardened_cflags "-Wl,-z,lazy"
%global _hardened_ldflags "-Wl,-z,lazy"

Does anyone here have a working recipe for building Slurm v22 on a Fedora 9 system (CentOS9, Rocky9)? Is there an expected delivery date for official Slurm packages in EPEL 9 yet?


Mark Holliman
Senior Data Systems Specialist
Wide Field Astronomy Unit
Institute for Astronomy
University of Edinburgh
The University of Edinburgh is a charitable body, registered in Scotland, with registration number SC005336.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20221128/a45a3be2/attachment-0001.htm>

More information about the slurm-users mailing list