[slurm-users] How to enable QOS correctly?

Matthew BETTINGER matthew.bettinger at external.total.com
Tue Mar 5 18:09:42 UTC 2019


Hey there 

Everyone's qos is 'normal'  so,
sacctmgr show associations format=account,user,qos
   Account       User                  QOS
---------- ---------- --------------------
  ...... 
  dgstaff   j0458951               normal
   ep   	    l0525429               normal
...


We tried to do this change yesterday and unfortunately do not see anything in yesterdays log and not sure how to get  old job history.  Scontrol show job looks like it has rolled off from when we had to restart slurmctld.

I have another slurm install, without cray plugins enabled and qos works fine.  Just do not know enough about this and how to test again without causing disruption.  Inch high a mile wide over here with 3-4 different schedulers.  

´╗┐On 3/5/19, 11:29 AM, "slurm-users on behalf of Christopher Samuel" <slurm-users-bounces at lists.schedmd.com on behalf of chris at csamuel.org> wrote:

    On 3/5/19 7:37 AM, Matthew BETTINGER wrote:
    
    > Every time we attempt this no one can submit a job, slurm says waiting on resources I believe.
    > 
    > We have accounting enabled  and everyone is a member of the default qos group "normal".
    
    Is it also their default QOS?
    
    Do you still have the slurmctld logs from one of these attempts?
    
    All the best,
    Chris
    -- 
       Chris Samuel  :  http://www.csamuel.org/  :  Berkeley, CA, USA
    
    



More information about the slurm-users mailing list