[slurm-users] Need help with controller issues

William Brown william at signalbox.org.uk
Thu Dec 12 09:09:52 UTC 2019

I looked back in the list to November when I had the same problem problem
building with MariaDB:
>>>> On 11-11-2019 21:23, William Brown wrote:
>>>>> I have in fact found the answer by looking harder.
>>>>> The config.log clearly showed that the build of the test MySQL
>>>>> program failed, which is why it was set to be excluded.
>>>>> It failed to link against '-lmariadb'.  It turns out that library is
>>>>> no longer in MariaDB or MariaDB-devel, it is separately packaged in
>>>>> MariaDB-shared.  That may of course be because I have built MariaDB
>>>>> 10.4 from the mariadb.org site, because CentOS 7 only ships with the
>>>>> extremely old version 5.5.
>>>>> Once I installed the missing package it built the RPMs just fine.
>>>>> However it would be easier to use it linked to static MariaDB
>>>>> libraries, as I now have to installed MariaDB-shared on every server
>>>>> that will run slurmd, i.e. all compute nodes.  I expect that if I
>>>>> looked harder at the build options there may be a way to do this,
>>>>> perhaps with linker flags.

I think that even if you are building with MySQL on a clean VM you need to
look at the detailed log of the build of the accounting components.

The configure looks and if it finds either mysql_config or mariadb_config
commands it assumes that you need to build with MySQL support.  In your
case you actually want it, where I really didn't as I use slurmdbd, not a
direct connect to MySQL.  It was then a matter of having the right RPMs
installed, and for MariaDB the missing bit was MariaDB-shared (this is for
RHEL/CentOS).  As soon as I had installed that I was able to get the
accounting_storage_mysql to build.

On Thu, 12 Dec 2019 at 03:54, <dean.w.schulze at gmail.com> wrote:

> Is that logged somewhere or do I need to capture the output from the make
> command to a file?
> -----Original Message-----
> From: slurm-users <slurm-users-bounces at lists.schedmd.com> On Behalf Of
> Kurt
> H Maier
> Sent: Wednesday, December 11, 2019 6:32 PM
> To: Slurm User Community List <slurm-users at lists.schedmd.com>
> Subject: Re: [slurm-users] Need help with controller issues
> On Wed, Dec 11, 2019 at 04:04:44PM -0700, Dean Schulze wrote:
> > I tried again with a completely new system (virtual machine).  I used
> > the latest source, I used mysql instead of mariadb, and I installed
> > all the client and dev libs (below).  I still get the same error.  It
> > doesn't build the /usr/lib/slurm/accounting_storage_mysql.so file.
> >
> > Could the ./configure command be the problem?  Here's how I run it:
> It's going to be extremely difficult to diagnose this without the output
> from the build process.  Perhaps you could attach this to the bug report
> you
> opened about this issue.
> khm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20191212/205e67b4/attachment.htm>

More information about the slurm-users mailing list