[slurm-users] Fwd: Problem installing slurm on computer cluster

John Hearns hearnsj at gmail.com
Thu Nov 16 07:02:38 MST 2017

Forgive me for saying this. I do have a bit of experience in building HPC
Distro supplied software packages have improved a lot over the years.
But they do tend to be out of date compared to the latest versions of (say)
I really would say you should consider downloading and installing from the
vendors site.
The same thing goes for compilers, MPI, and many software packages.

Yes, the distro supplied debs or RPMs are easy to install and will be
tested against that distro.
But (again) they will eb installed locally on the nodes. So again with
compilers, MPI , Python modules....
you tend to instlal these on a network shared drive so that you have one
central install.

On 16 November 2017 at 14:47, E V <eliventer at gmail.com> wrote:

> You may need to install a systemd override file if you have some of
> the system config left over, it has the path set to /usr/bin/. Example
> for slurmd, slurmctld and slurmdbd are the same just changing the
> names:
> cat /etc/systemd/system/slurmd.service.d/override.conf
> [Service]
> ExecStart=
> ExecStart=/usr/local/sbin/slurmd $SLURMD_OPTIONS
> On Wed, Nov 15, 2017 at 12:37 PM, Bruno Santos <bacmsantos at gmail.com>
> wrote:
> > Hi everyone,
> >
> > I am currently trying to install slurm to serve as a job scheduler for a
> > research institute. I have installed Debian stretch and initially
> installed
> > and configured slurm from the repos.
> > HoweverI then tried to play with a different server serving as node and
> > realized that due to the different versions of debian the controller and
> the
> > daemon where running different versions of slurm and so not working.
> > I have since done apt-get remove --purge and tried to install slurm from
> > src. But it seems that the old configuration is still stuck somewhere as
> > when I try to run:
> >
> > #systemctl enable slurmctld
> > Synchronizing state of slurmctld.service with SysV service script with
> > /lib/systemd/systemd-sysv-install.
> > Executing: /lib/systemd/systemd-sysv-install enable slurmctld
> > Failed to enable unit: Unit file /etc/systemd/system/slurmctld.service
> is
> > masked.
> > # whereis slurmctld
> > slurmctld: /usr/local/sbin/slurmctld
> > # slurmctld
> > bash: /usr/sbin/slurmctld: No such file or directory
> >
> > Any idea what could be going wrong?
> >
> > Thank you very much in advance.
> > Best,
> > Bruno
> >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20171116/29c0c8bf/attachment.html>

More information about the slurm-users mailing list