[slurm-users] [slurm-dev] Re: Installing SLURM locally on Ubuntu 16.04

Will L will.landau at gmail.com
Sat Nov 11 05:12:59 MST 2017

I am trying what you said, but I am having new and earlier problems. For
example, now munge does not start.

$ sudo systemctl enable munge
Synchronizing state of munge.service with SysV init with
Executing /lib/systemd/systemd-sysv-install enable munge
Failed to execute operation: File exists

I really think I mangled my system because I tried so many different
things. Is there a way to start fresh without reinstalling my OS?


On Thu, Nov 9, 2017 at 3:04 AM, Raymond Wan <rwan.work at gmail.com> wrote:

> Hi Will,
> On Thu, Nov 9, 2017 at 11:01 AM, Will L <will.landau at gmail.com> wrote:
> >
> > Thanks for the suggestions. Munge seems to be working just fine. At one
> point I tried to build SLURM from the source, but when I could not make it
> work, I `sudo make uninstall`ed it and opted for the pre-built apt version
> all over again. Maybe that made a mess. What should I do to make SLURM
> notice munge and other utilities?
> Yes, that wasn't probably a good idea.  I've had SLURM working on a
> single computer since Ubuntu 15.04 or 15.10 using the packages without
> a lot of problems.  I haven't had to turn to installing from source
> [yet]...
> During the setup of munge, you ran commands such as this:
> sudo create-munge-key -f -r
> sudo systemctl enable munge
> sudo systemctl start munge
> (I guess the third line doesn't matter if you reboot.)
> So, after you rebooted, did you see /usr/sbin/munged running and owned
> by the munge user?
> > Also, here is my current slurm.conf.
> One issue I had with the SLURM packages for Ubuntu (especially 1-2
> years ago) was that the configurator at
> /usr/share/doc/slurmctld/slurm-wlm-configurator.html did *not* match
> the version I was installing.  So I actually ended up using a
> web-based configurator.
> I'm not sure if that's a big problem...
> Another problem with the "older" [*] SLURM packages for Ubuntu is that
> many directories are not created during the installation process.  So,
> in your configuration file, make sure all of the directories
> /var/run/... /var/log/... have all been created and accessible by the
> slurm user, at least.  First ensure that the log directories are
> created...once they are, watch the log files when you do:
> sudo service slurmctld start
> sudo service slurmd start
> and it'll tell you what directories are missing.  Actually, once you
> get to the point where there are log files being generated, you're not
> only close, but posting the error message might help us help you
> better.
> This is what comes to mind; I hope this helps!
> Ray
> [*]  I'm currently on Ubuntu 17.10 and the SLURM packages for that
> version.  Ubuntu 16.04 is fine, but I haven't kept track of what has
> changed / improved in terms of the SLURM packages...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20171111/8ee4b05a/attachment.html>

More information about the slurm-users mailing list