[slurm-users] container on slurm cluster

GHui ugiwgh at qq.com
Wed May 18 07:13:55 UTC 2022

Hi, Hermann

Yes, I run podman as non-root, and use the root inside the container. 
But the root in container has only privilege non-root which I run podman-command.

[]$ podman info | grep root
    rootless: true

I exec "sbatch sub.sh" to submit inside the container.

I had config the right slurm and munge inside the container.

I just want to run some software in container, in order to get out of host OS environment.
On a whim, I config the slurm on container and submit a job.

On 5/17/22 16:10:55, Hermann wrote:
> fyi: I am not a podman-expert so my questions might be stupid. :-)
> From what you told us so far you are running the podman-command as 
> non-root but you are root inside the container, right?
> What is the output of "podman info | grep root" in your case?
> How are you submitting a job from inside the container?
> You have to have Slurm and munge installed and correctly configured
> inside the container for that, right?
> Why are you using such a container in the first place?
>> On 5/17/22 7:49 AM, GHui wrote:
>> I use podman 4.0.2. And slurm 21.08.8-2.
>> I run container on my host with username rsync. And it only has itself privilege.
>> I create the same username, UID and GID in container with the host.
>> I run "podman exec -it <container>> /bin/bash" to login with host user rsync. And the user is root on container.
>> Now I submit job with root in container. And job is running on host. And the job's owner is root.
>> So I submit a job with user rsync, but it runs as root privilege.
>> On 5/16/22 7:53 AM, GHui wrote:
>>> I fount a serious problem. If I run a container on a common user, eg. tom. In container I switch user to jack, now, if I submit a job to slurm cluster, the job owner is jack.
>>> So I use the tom account submit a jack's job.
>>> Any help will be appreciated.
>>> --GHui</container>

More information about the slurm-users mailing list