[slurm-users] Problems building RPMs

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Fri Jul 22 09:35:33 UTC 2022

On 7/22/22 11:14, Phill Harvey-Smith wrote:
> On 21/07/2022 18:42, Brian Andrus wrote:
>> Hmm. That would imply you could still use the tar file with something like:
>> rpmbuild -v -ta --define "_lto_cflags %{nil}" slurm-22.05.2.tar.bz2
>> Note, I have not tried this (no immediate access to RHEL9 derivative), 
>> so YMMV.
> Right tried that, and I stopped getting the gnu.debug messages but now 
> getting the following :
> Processing files: slurm-slurmdbd-22.05.2-1.el9.x86_64
> error: File not found: 
> /root/rpmbuild/BUILDROOT/slurm-22.05.2-1.el9.x86_64/usr/lib64/slurm/accounting_storage_mysql.so 
> My build command line is :
> rpmbuild -v -ta --define "_lto_cflags %{nil}" slurm-22.05.2.tar.bz2
> I also tried --without mysql but that didn't change the error --with mysql 
> threw an error that mysql-devel was not installed, but doesn't seem 
> available in yum.

You should probably install the database RPMs before building Slurm:

dnf install mariadb-server mariadb-devel

Also make sure that you have all prerequisites, see my Wiki page 

If --without mysql still fails without the database RPMs, that would 
indicate a bug in the spec file.  The spec file works fine on EL8, however.

This check is useful after you have installed slurm-slurmdbd:

rpm -ql slurm-slurmdbd | grep accounting_storage_mysql.so


More information about the slurm-users mailing list