[slurm-users] incorrectly added account and now get "AssocGrpCPUMinutesLimit" when trying to run job

byron lbgpublic at gmail.com
Mon Nov 29 23:19:18 UTC 2021

I’m trying to replicate the setup of a new account where there is a new
“grouping” of accounts and a new account that will actually be used, so
something like this when you run
sacctmgr show assoc tree

mycluster   account1.           (which is just being used to group accounts
and so has no GrpTRESMins assocliated
mycluster        account2.      (which is used as an account for running
jobs and does have GrpTRESMins associated)

I’ve tried setting it up like this

I’ve add a new project with sbank using

sbank project create -c mycluster -a mynewaccount1

Moved it to where I want it

sacctmgr modify account mynewaccount1 set parent=projects

And the created the account to sit below it

sbank project create -c mycluster -a mynewaccount2

and moved that

sacctmgr modify account mynewaccount2 set parent=mynewaccount1

Add a user

sbank project useradd -c mycluster -a mynewaccount2 -u user1

add hours to the account
sbank deposit -c mycluster -a mynewaccount2 -t 50000

The problem is that when the user tries to run a job from the account
mynewaccount2 it gets held in the queue with the reason

and when I run
sacctmgr show assoc tree

mycluster.     mynewaccount1.                       cpu=0
mycluster.           Mynewaccount2.                cpu=3000000

Now I’m guessing that the problem is the cpu=0 because the account /
subaccount setup by my predecessor and which works doesnt have this

And I’ve tried getting rid of the cpu=0 by using

sacctmgr modify account mynewaccount1 set=GrpTRESMins=cpu=-1

But the command just hangs and does nothing.

I’m guessing I’ve setup mynewaccount1 incorectly?  Any help appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20211129/295c0f42/attachment.htm>

More information about the slurm-users mailing list