[slurm-users] slurmrestd configuration

Simone Riggi simone.riggi at gmail.com
Thu Apr 8 07:50:49 UTC 2021

Dear all,
I write you about how to properly setup slurmrestd.
I followed a recent post (
https://groups.google.com/g/slurm-users/c/VDeFmSDao1U/m/Yu0j-VNcBgAJ) but
slurmrestd fails with:

*slurmrestd: fatal: No authentication plugins to load*

Indeed when I run slurmrestd -a list, no plugin is detected.
Can you provide some additional documentation explaining what
authentication plugins I should use, how to install and configure them? I
was not able to understand from the current documentation if this works
only with jwt or there is a default plugin.

I try to describe what I did:

OS: Centos 7
Slurm: v20.11.5

1) Installed the dependencies, among which libjwt. I verified it is
installed under /usr/lib64:

rpm -qa | grep jwt

2) Installed slurm with:

rpmbuild -ta slurm-20.11.5.tar.bz2 --with mysql --with slurmrestd --with jwt

3) Added these options to /etc/slurm/slurm.conf


4) Started daemons. I attach the logs:

== slurmctld ==
2021-04-07T20:34:10.148] slurmctld version 20.11.5 started on cluster
[2021-04-07T20:34:10.153] No memory enforcing mechanism configured.
[2021-04-07T20:34:10.219] Recovered state of 1 nodes
[2021-04-07T20:34:10.219] Recovered information about 0 jobs
[2021-04-07T20:34:10.219] select/cons_tres: part_data_create_array:
select/cons_tres: preparing for 1 partitions
[2021-04-07T20:34:10.219] Recovered state of 0 reservations
[2021-04-07T20:34:10.219] read_slurm_conf: backup_controller not specified
[2021-04-07T20:34:10.219] select/cons_tres: select_p_reconfigure:
select/cons_tres: reconfigure
[2021-04-07T20:34:10.219] select/cons_tres: part_data_create_array:
select/cons_tres: preparing for 1 partitions
[2021-04-07T20:34:10.219] Running as primary controller
[2021-04-07T20:34:10.220] No parameter for mcs plugin, default values set
[2021-04-07T20:34:10.220] mcs: MCSParameters = (null). ondemand set.

== slurmd ==
[2021-04-07T20:35:37.939] slurmd version 20.11.5 started
[2021-04-07T20:35:37.940] slurmd started on Wed, 07 Apr 2021 20:35:37 +0200
[2021-04-07T20:35:37.940] CPUs=40 Boards=1 Sockets=4 Cores=10 Threads=2
Memory=128529 TmpDisk=51175 Uptime=5391270 CPUSpecList=(null)
FeaturesAvail=(null) FeaturesActive=(null)

== slurmrestd ==
$ systemctl start slurmrestd
slurmrestd[1987721]: fatal: No authentication plugins to load

Same result with this (as root user) following the old post:

$ slurmrestd -f /etc/slurm/slurmrestd.conf

where /etc/slurm/slurmrestd.conf

include /etc/slurm/slurm.conf

Any hints?

Thanks very much for your help,



Simone Riggi, PhD
INAF, Osservatorio Astrofisico di Catania
Via S. Sofia 78
95123, Catania - Italy
phone:  +39 095 7332 extension 282 (or 310)
e-mail: simone.riggi at gmail.com,
            sriggi at inaf.it <sriggi at oact.inaf.it>,
            sriggi at pec.it <simone.riggi at ct.infn.it>
skype: simone.riggi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20210408/48c2ab7e/attachment.htm>

More information about the slurm-users mailing list