[slurm-users] Issue with x11

Sean Crosby scrosby at unimelb.edu.au
Wed May 15 00:30:21 UTC 2019

Hi Mahmood,

Are you physically logged into rocks7? Or are you connecting via SSH? $DISPLAY = :1 kind of means that you are physically logged into the machine


Sean Crosby
Senior DevOpsHPC Engineer and HPC Team Lead | Research Platform Services
Research Computing | CoEPP | School of Physics
University of Melbourne

On Wed, 15 May 2019 at 10:09, Mahmood Naderan <mahmood.nt at gmail.com<mailto:mahmood.nt at gmail.com>> wrote:
>What does this say?
>echo $DISPLAY

On frontend of compute-0-0?
[mahmood at rocks7 ~]$ echo $DISPLAY

>To get native X11 working with SLURM, we had to add this config to sshd_config on the login node (your rocks7 host)
>X11UseLocalhost no
>You'll then need to restart sshd

I checked that and it was commented. I modified that and restarted the service. But still get the same error

[root at rocks7 mahmood]# grep X11UseLocalhost /etc/ssh/sshd_config
#X11UseLocalhost yes
[root at rocks7 mahmood]# vim /etc/ssh/sshd_config
[root at rocks7 mahmood]# systemctl restart sshd
sshd@                sshd-keygen.service  sshd.service         sshd.socket
[root at rocks7 mahmood]# systemctl restart sshd
[root at rocks7 mahmood]# grep X11UseLocalhost /etc/ssh/sshd_config
X11UseLocalhost no
[root at rocks7 mahmood]# exit
[mahmood at rocks7 ~]$ srun --x11 --nodelist=compute-0-0 --account y4 --partition RUBY -n 1 -c 4 --mem=1GB  xclock
srun: error: Cannot forward to local display. Can only use X11 forwarding with network displays.

Should I modify that parameter on compute-0-0 too?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20190515/41cfde8e/attachment-0001.html>

More information about the slurm-users mailing list