[slurm-users] Need help with controller issues

Dean Schulze dean.w.schulze at gmail.com
Wed Dec 11 23:04:44 UTC 2019

I tried again with a completely new system (virtual machine).  I used the
latest source, I used mysql instead of mariadb, and I installed all the
client and dev libs (below).  I still get the same error.  It doesn't
build the /usr/lib/slurm/accounting_storage_mysql.so file.

Could the ./configure command be the problem?  Here's how I run it:

./configure --prefix=/tmp/slurm-build --sysconfdir=/etc/slurm --enable-pam
--with-pam_dir=/lib/x86_64-linux-gnu/security/ --without-shared-libslurm

$ dpkg -l | grep mysql
ii  libmysqlclient-dev                         5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database development files
ii  libmysqlclient20:amd64                     5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database client library
ii  libmysqld-dev                              5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL embedded database development files
ii  mysql-client                               5.7.28-0ubuntu0.18.04.4
                    all          MySQL database client (metapackage
depending on the latest version)
ii  mysql-client-5.7                           5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database client binaries
ii  mysql-client-core-5.7                      5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database core client binaries
ii  mysql-common                               5.8+1.0.4
                    all          MySQL database common files, e.g.
ii  mysql-server                               5.7.28-0ubuntu0.18.04.4
                    all          MySQL database server (metapackage
depending on the latest version)
ii  mysql-server-5.7                           5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database server binaries and system
database setup
ii  mysql-server-core-5.7                      5.7.28-0ubuntu0.18.04.4
                    amd64        MySQL database server binaries

On Tue, Dec 10, 2019 at 2:05 PM Dean Schulze <dean.w.schulze at gmail.com>

> I'm trying to set up my first slurm installation following these
> instructions:
> https://github.com/nateGeorge/slurm_gpu_ubuntu
> I've had to deviate a little bit because I'm using virtual machines that
> don't have GPUs, so I don't have a gres.conf file and in
> /etc/slurm/slurm.conf I don't have an entry like Gres=gpu:2 on the last
> line.
> On my controller vm I get errors when trying to do simple commnands:
> $ sinfo
> slurm_load_partitions: Unable to contact slurm controller (connect failure)
> $ sudo sacctmgr add cluster compute-cluster
> sacctmgr: error: slurm_persist_conn_open_without_init: failed to open
> persistent connection to localhost:6819: Connection refused
> sacctmgr: error: slurmdbd: Sending PersistInit msg: Connection refused
> sacctmgr: error: Problem talking to the database: Connection refused
> Something is supposed to be running on port 6819, but netstat shows
> nothing using that port.  What is supposed to be running on 6819?
> My database (Maria) is running.  I can connect to it with `sudo mysql -U
> root`.
> When I boot my controller which services are supposed to be running and on
> which ports?
> Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20191211/ec466479/attachment.htm>

More information about the slurm-users mailing list