[slurm-users] AllocNodes on partition no longer working

Sajdak, Doris djm29 at buffalo.edu
Thu Aug 15 14:18:28 UTC 2019

Thanks Chris!  That worked.  We'd tried IP address but not FQDN.


-----Original Message-----
From: slurm-users <slurm-users-bounces at lists.schedmd.com> On Behalf Of Christopher Samuel
Sent: Wednesday, August 14, 2019 5:11 PM
To: slurm-users at lists.schedmd.com
Subject: Re: [slurm-users] AllocNodes on partition no longer working

On 8/14/19 10:46 AM, Sajdak, Doris wrote:

> We upgraded from version 18.08.4 to 19.05.1-2 today and are suddenly 
> getting a permission denied error on partitions where we have 
> AllocNodes set.  If we remove the AllocNodes constraint, the job 
> submits successfully but then users can submit from anywhere which is 
> not what we want.  Has anyone else seen this problem?
> sbatch: error: Batch job submission failed: Access/permission denied

It's working here - though we got caught out with that because the IP address was being resolved to the FQDN of the node and not the short name we had in our config file.

To see what your system is resolving the IP address to now use scontrol to set your debug level to "debug2" and see what it reports when the test fails (it would be nice if Slurm actually logged that as an error).

All the best,
   Chris Samuel  :  http://www.csamuel.org/  :  Berkeley, CA, USA

More information about the slurm-users mailing list