[slurm-users] "cannot find auth plugin for auth/munge" with slurm-llnl

Eli V eliventer at gmail.com
Fri Sep 28 11:24:30 MDT 2018

Have you started the munge service? The order should be roughly, start
munge, start mysql/mariadb, start slurmdbd, start slurmctld, start
slurmd. You didn't mention which distribution you're using. On recent
debian versions the 3 slurm daemons have been split out independently
and you'll probably be better off installing them instead of the
slurm-llnl/wlm overall package since you only need the slurmdbd &
slurmctld on one or 2 nodes.
On Fri, Sep 28, 2018 at 12:52 PM Alan Do-Omri
<alan.do-omri at mail.mcgill.ca> wrote:
> Hey,
> I have been trying to set up slurm for the last few days but I keep stumbling upon the error whenever I run sudo slurmdbd -D:
> slurmdbd: error: Couldn't find the specified plugin name for auth/munge looking at all files
> slurmdbd: error: cannot find auth plugin for auth/munge
> slurmdbd: error: cannot create auth context for auth/munge
> slurmdbd: fatal: Unable to initialize auth/munge authentication plugin
> When I run sudo slurmd -D, I get the following errors:
> slurmd: slurmd version 15.08.7 started
> slurmd: error: Error binding slurm stream socket: Address already in use
> slurmd: error: Unable to bind listen port (*:6818): Address already in use
> I have set up my firewall to accept connections to these ports, however.
> When I run sudo sacctmgr -vvvv, I get the following:
> sacctmgr: debug3: Trying to load plugin /usr/lib/x86_64-linux-gnu/slurm/accounting_storage_slurmdbd.so
> sacctmgr: Accounting storage SLURMDBD plugin loaded with AuthInfo=/var/run/munge/munge.socket.2
> sacctmgr: debug3: Success.
> sacctmgr: debug2: slurm_connect failed: Connection refused
> sacctmgr: debug2: Error connecting slurm stream socket at Connection refused
> sacctmgr: debug:  slurmdbd: slurm_open_msg_conn to localhost:8080: Connection refused
> sacctmgr: error: Problem talking to the database: Connection refused
> In my slurm.conf file I have
> SlurmUser=slurm
> SlurmctldPort=6817
> SlurmdPort=6818
> AuthType=auth/munge
> AccountingStorageType=accounting_storage/slurmdbd
> AccountingStoragePort=6819
> AccountingStorageHost=localhost
> #AccountingStorageLoc=
> AccountingStoragePass=/var/run/munge/munge.socket.2
> AccountingStorageUser=slurm
> (among other
> In my slurmdbd.conf file I have
> DbdAddr=localhost
> DbdHost=localhost
> DbdPort=6819
> SlurmUser=slurm
> StorageType=accounting_storage/mysql
> StoragePass=myslurmpassword
> StorageUser=slurm
> StorageLoc=slurm_acct_db
> and in the MySQL database, I have also done
> grant usage on *.* to 'slurm'@'localhost';
> grant all privileges on slurm_acct_db.* to 'slurm'@'localhost';
> flush privileges;
> Slurm was installed using sudo apt install slurm-llnl.
> I have done some research to try to solve this problem and I found some solutions but they didn't work for me. Two of them that I found were
> 1. To install munge development librairies: I have done this by doing sudo apt install libmunge-dev libmunge2
> 2. Using this https://groups.google.com/forum/#!searchin/slurm-users/unable$20to$20find$20auth$20munge%7Csort:date/slurm-users/Igm-moubmlM/OS26x2mNCAAJ to fix the library locations.
> Even after these two solutions, I am unable to fix the problem.
> Thank you for your help!
> Alan

More information about the slurm-users mailing list