[slurm-users] Finding / compiling "pam_slurm.so" for Ubuntu 16.04

Will Dennis wdennis at nec-labs.com
Fri May 4 15:11:53 MDT 2018

I just tried unpacking the original archive, and running “./configure, make, make contrib” but no luck – still no ‘pam_slurm.so’ file created... What am I missing here?

From: slurm-users [mailto:slurm-users-bounces at lists.schedmd.com] On Behalf Of Will Dennis
Sent: Friday, May 04, 2018 2:50 PM
To: slurm-users at lists.schedmd.com
Subject: Re: [slurm-users] Finding / compiling "pam_slurm.so" for Ubuntu 16.04

(trying to reply to Gennaro Oliva’s message as I did not receive a copy of my original mssg or reply from the list – fixed now)

I built my .deb from the Slurm sources via the following method:

·         Downloaded the then-current Slurm source ‘slurm-16.05.4.tar.bz2’ from schedmd.com

·         Renamed & converted to .tar.gz to fit Debian packaging guidelines:  bunzip2 -c < slurm-16.05.4.tar.bz2 | gzip -9 -c > slurm-wlm-necla_16.05.4.orig.tar.gz

·         Unpacked the tarball

·         Decended into the unpacked source directory, and created a subdir named ‘debian’

·         In the debian directory, created the requisite packaging files

·         Then ran the command ‘debuild -us –uc’ in the top-level source directory  to compile the source and package it into a .deb file

The result was (only) one .deb file, namely ‘slurm-wlm-necla_16.05.4-1_amd64.deb’. As noted before, this contained many .so files, but not ‘pam_slurm.so’.

I could build the needed ‘pam_slurm.so’ file directly, but my attempts so far have failed (ran ‘./configure’ in the top-level unpacked source dir, then descended into contribs/pam and ran ‘make’, which failed with the message “make: Nothing to be done for 'all'.”)

From: Will Dennis
Sent: Thursday, May 03, 2018 11:07 PM
To: slurm-users at lists.schedmd.com<mailto:slurm-users at lists.schedmd.com>
Subject: Finding / compiling "pam_slurm.so" for Ubuntu 16.04

Hello everyone,

Back a year ago or so, I started a new SLURM cluster, and had produced a .deb file from the then-current release archive (v16.05.4) that I compiled on a U16.04 host. I have successfully used that .deb which I included in our local custom repo to roll out the compute nodes of my cluster (which also run U16.04 of course.) For what we have tried to do with it, it all appears to work well.

Now I am attempting to restrict users from logging into the compute nodes via the “pam_slurm” module as described at https://raw.githubusercontent.com/SchedMD/slurm/5505db3a5076bfc301dba16e83fbc133e833cbd4/contribs/pam/README. I put the following lines in the /etc/pam.d/sshd file at the bottom:

account    sufficient   pam_succeed_if.so user ingroup SYSOPS
account    required     pam_slurm.so

Unfortunately, I got a report that my users can not log into the compute nodes even when they have a job scheduled on the node. I came to find out that although I have many .so files from my .deb package all in /usr/lib/x86_64-linux-gnu/slurm, pam_slurm.so is not one of them... My question is, where could I acquire the proper pam_slurm.so shared lib file for U16.04, or, otherwise, how to compile it?


Will Dennis
Sr. Systems Administrator,
NEC Laboratories America
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.schedmd.com/pipermail/slurm-users/attachments/20180504/c9532920/attachment-0001.html>

More information about the slurm-users mailing list