[slurm-users] MariaDB lock problems for sacctmgr delete query

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Fri Feb 16 04:23:13 MST 2018

We're planning to upgrade Slurm 17.02 to 17.11 soon, so it's important 
for us to test the slurmdbd and database upgrade before doing the actual 

I've made a *successful* upgrade of the database migration from 17.02 to 
17.11, making a dry run on an offlined compute node running CentOS 7.4.

The dry run procedure has been documented in my Slurm Wiki page:

I tried Jessica's problem command, and it didn't cause any errors in my 

# sacctmgr -i delete account where account=XXX cluster=niflheim

At least it appears that we don't get hurt by Slurm Bug 4785 referred to 
in the page mentioned below.

Question: Is it safer to wait for 17.11.4 where the issue will 
presumably be solved?

On 02/14/2018 09:32 PM, Jessica Nettelblad wrote:
> FYI - SchedMD has now solved the issue in the master branch.
> https://github.com/SchedMD/slurm/commit/4a16541bf0e005e1984afd4201b97df482e269ee#diff-7649dde209b4e528e3ba8bb090b19f63
> Best regards,
> Jessica Nettelblad, UPPMAX
> On Wed, Feb 14, 2018 at 3:31 PM, Bjørn-Helge Mevik 
> <b.h.mevik at usit.uio.no <mailto:b.h.mevik at usit.uio.no>> wrote:
>     Thanks for the heads-up!  We're currently runnint 17.02.7 with MariaDB,
>     and haven't seen this problem, but we are going to upgrade to 17.11 in
>     the not-to-far-future.


More information about the slurm-users mailing list